开源中文网

您的位置: 首页 > Gentoo > 正文

linux下Gentoo安装kde5配置教程

来源: 网络整理  作者: 佚名

Gentoo是一个不错的开源的工具了,使用Gentoo的朋友相对其它系统来说并不多了,但小编就用到了下文为各位介绍一下Gentoo安装kde5配置教程,有需要的可以来看看。

kde5出来已经很长一段时间了,虽然没有达到完全可用的程度,但从目前个人使用来看,日常使用也基本差不多了。下面把个人安装使用的一些方法做一说明,仅供参考。
参考:https://wiki.gentoo.org/wiki/KDE/Overlay
1、添加kde的overlay:
layman -a kde
echo -e "-qt5" >> /etc/portage/profile/use.stable.mask
或者在/etc/portage/make.conf的USE中添加qt5。
2、解除kde5的mask
方法一:按官方wiki中的方法做软链接:
cd /etc/portage/package.accept_keywords
ln -s /var/lib/layman/kde/Documentation/package.accept_keywords/kde-frameworks-5.9.keywords
ln -s /var/lib/layman/kde/Documentation/package.accept_keywords/kde-plasma-5.2.keywords
方法二:来个简单粗暴的方式(不建议):
rm /var/lib/layman/kde/profiles/package.mask/frameworks*
rm /var/lib/layman/kde/profiles/package.mask/plasma*
方法三:将mask掉的包加到/etc/portage/package.unmask中(注:根据实际情况自行修改参数):
cat /var/lib/layman/kde/profiles/package.mask/plasma-5.3.0 >> /etc/portage/package.unmask
cat /var/lib/layman/kde/profiles/package.mask/kde-apps-15.04.0 >> /etc/portage/package.unmask
sed -i "s/\~//g;s/-15.04.0//g;s/-5.9.0//g;s/-5.3.0//g" /etc/portage/package.unmask
我用的是方法三。
3、安装frameworks和plasma
emerge @kde-frameworks @kde-plasma
这一步最麻烦,会遇到多个包block或者collisions,采用简单粗暴的方法即可,遇到哪个包有问题就干掉它。
还有一个问题是,gentoo开发者会在kde官方发布之前,提前把kde5的ebuild写出来,比如现在的plasma-5.3.0,这个得需要自己看具体情况去处理了。
4、kde5组件的安装
现在kde5下的应用移植还不完全,有些软件连测试版都没有,只好兼容kde4下的,比如以kde-apps-14.12.3这种形式的包出现。目前我使用的测试版本软件有(cat /etc/portage/package.keywords):
=kde-apps/dolphin-9999 **
=kde-apps/libkonq-5.9999 **
=kde-apps/kcalc-9999 **
=kde-apps/ksnapshot-5.9999 **
=kde-apps/okular-5.9999 **
=kde-apps/libkexiv2-5.9999 **
=kde-apps/kmix-5.9999 **
=kde-apps/ark-5.9999 **
其中kde-apps/libkonq包是dolphin添加右键菜单支持的包。
将包添加到package.keywords后,安装方式如下:
emerge -av =kde-apps/ark-5.9999
5、系统托盘图标问题
qt4程序在kde5下没有系统托盘,需要安装sni-qt这个包,比如qBittorrent等软件。
gtk程序及wineQQ需要安装wmsystemtray(需要自己安装font-misc-misc这个字体包)这个包来实现托盘,但无法放到系统托盘。
6、kde5不能用kdm来引导桌面环境,安装sddm,取代kdm。
emerge -av sddm
7、设置qt5为默认qt编译器
cd /etc/xdg/qtchooser/
rm default.conf
ln -s qt5.conf default.conf
8、输入法,fcitx需要安装gentoo-zh的overlay中的fcitx-qt5这个包:
emerge fcitx-qt5

Tags:教程
关于开源中文网 - 联系我们 - 广告服务 - 网站地图 - 版权声明