开源中文网

您的位置: 首页 > Debian Linux > 正文

Debian 8 安装录屏软件kazam

来源: cnblogs  作者: ibg

1 安装

复制代码
$ sudo apt-get install kazam
[sudo] password for z: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
将会安装下列额外的软件包:
  dh-python gir1.2-keybinder-3.0 gir1.2-wnck-3.0 gnome-session-canberra
  gstreamer1.0-libav gstreamer1.0-pulseaudio libcanberra-gtk-module
  libcanberra-gtk0 libkeybinder-3.0-0 libmpdec2 libpython3-stdlib
  libpython3.4-minimal libpython3.4-stdlib libwnck-3-0 libwnck-3-common
  python3 python3-cairo python3-dbus python3-gi python3-gi-cairo
  python3-minimal python3-xdg python3.4 python3.4-minimal
建议安装的软件包:
  python3-doc python3-tk python3-venv python-dbus-doc python3-dbus-dbg
  python3.4-venv python3.4-doc binfmt-support
下列【新】软件包将被安装:
  dh-python gir1.2-keybinder-3.0 gir1.2-wnck-3.0 gnome-session-canberra
  gstreamer1.0-libav gstreamer1.0-pulseaudio kazam libcanberra-gtk-module
  libcanberra-gtk0 libkeybinder-3.0-0 libmpdec2 libpython3-stdlib
  libpython3.4-minimal libpython3.4-stdlib libwnck-3-0 libwnck-3-common
  python3 python3-cairo python3-dbus python3-gi python3-gi-cairo
  python3-minimal python3-xdg python3.4 python3.4-minimal
升级了 0 个软件包,新安装了 25 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
需要下载 8,386 kB 的软件包。
解压缩后会消耗掉 27.8 MB 的额外空间。
您希望继续执行吗? [Y/n] 
复制代码

若提示未安装pluseaudio则安装它。

复制代码
$ sudo apt-get install pulseaudio
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
将会安装下列额外的软件包:
  libasound2-plugins libfftw3-single3 libpulsedsp libwebrtc-audio-processing-0
  pulseaudio-module-x11 pulseaudio-utils rtkit
建议安装的软件包:
  libfftw3-bin libfftw3-dev pavumeter pavucontrol paman paprefs
下列【新】软件包将被安装:
  libasound2-plugins libfftw3-single3 libpulsedsp libwebrtc-audio-processing-0
  pulseaudio pulseaudio-module-x11 pulseaudio-utils rtkit
升级了 0 个软件包,新安装了 8 个软件包,要卸载 0 个软件包,有 7 个软件包未被升级。
需要下载 2,065 kB 的软件包。
解压缩后会消耗掉 8,428 kB 的额外空间。
您希望继续执行吗? [Y/n] 
复制代码

安装pulseaudio的控制面板:

复制代码
$ sudo apt-get install pavucontrol
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
将会安装下列额外的软件包:
  libatkmm-1.6-1 libcairomm-1.0-1 libglibmm-2.4-1c2a libgtkmm-3.0-1 libpangomm-1.4-1
  libpulse-mainloop-glib0
下列【新】软件包将被安装:
  libatkmm-1.6-1 libcairomm-1.0-1 libglibmm-2.4-1c2a libgtkmm-3.0-1 libpangomm-1.4-1
  libpulse-mainloop-glib0 pavucontrol
升级了 0 个软件包,新安装了 7 个软件包,要卸载 0 个软件包,有 7 个软件包未被升级。
需要下载 1,897 kB 的软件包。
解压缩后会消耗掉 12.3 MB 的额外空间。
您希望继续执行吗? [Y/n] 
复制代码

 

2 使用

安装后从菜单中选择kazam打开界面:

选择区域时可能会不显示,参考此处:https://bugs.launchpad.net/kazam/+bug/1030604

复制代码
This leads to a workaround (close to a fix) in Mint with Mate. Go to Desktop Settings (which, for me, is in System->Preferences, but not if you use the default menus), then click "Windows," then check "Use compositing." This fixes Kazam's "Record Region" issue, fixes the transparency issue in the "Recording will begin in" display, and I am wondering if it'll fix issues in other programs, too.

I seem to recall having an issue with CairoDock transparency that I think would be fixed with this option. Wow, great discovery, haha.
复制代码

在xfce4的窗口管理器微调中勾选“启用显示合成”:

若录屏的文件过大,则可以更改文件的格式,将默认的avi改为mp4(Record with):

 

注意:kazam不能使用自己来截自己的界面!

-- End --

Tags:kazam
相关文章列表:
关于开源中文网 - 联系我们 - 广告服务 - 网站地图 - 版权声明